96c5fea9fe2204c64edf27bf91794fda
Flutter-从入门到项目 02: 环境配置

Flutter 专栏目录直通车

Flutter-从入门到项目 01: Flutter重要性

Flutter-从入门到项目 02: 环境配置

Flutter-从入门到项目 03: Flutter初体验

Flutter-从入门到项目 04:Dart语法快速掌握(上)

Flutter-从入门到项目 05:Dart语法快速掌握(下)

Flutter-从入门到项目 06: 微信项目搭建

Flutter-从入门到项目 07: 微信项目-发现页面

这个篇章我们一起快速搭建 Flutter 的开发环境,同时会将搭建Flutter 开发环境中的一些技巧和经验分享给大家。
Flutter环境配置看我这一篇就够了! 😊😊😊

如果你在搭建 Flutter 的开发环境, 可以在留言区及时留言,我尽量会在第一时间和你联系 📮

一、Android下玩Flutter

1.下载并安装 Android Studio

这个地址下载可能会比较快一点: https://developer.android.google.cn/studio

2: 关于Android Studio配置

这里推荐一个非常非常详细的配置文档:

https://www.cnblogs.com/mengtaoadmin/p/11184052.html

如果大家还需额外配置或者遇到疑问的大家可以直接去Android官网查阅和交流

https://developer.android.google.cn/studio/intro

OK , 到这里我们暂时配置好安卓环境! 接下面去去安装 Flutter

4: 检查 HomeBrew (这个非常方便)

我们在去配置 Flutter 的环境之前,需要先检查一下 HomeBrew 是不是最新的! 如果没有的话就去 HomeBrew官网下载

5: 下载 Flutter SDK

官网SDK下载地址 速度还是挺快的! 当然也可以通过 👇 去 clone

git clone -b beta https://github.com/flutter/flutter.git

我这里就看到官网下载速度挺快,就自己下载解压缩,网上也有很多人说上面的 clone 挺费时间. 既然快速学习就不去不必要的采坑 😄

然后提取文件到所需的位置

因为Flutter的SDK中包含了很多命令行工具。我们需要配置环境变量,所以建议你安装到你平时放命令行工具程序的地方! 我这里安装在了根目录的 opt 下!
/opt/flutter (仅供参考,安装在哪里看你自己的习惯)

5: 配置环境变量

因为 Flutter 在运行的时候,需要去官方下载所需要的资源.那么没有“梯子”的伙伴你会需要镜像服务器,以下是官方文档的友情提示

  • 来到你对应 Shell 的配置文件进行配置。

  • 如果你使用默认的bash那么配置 ~/.bash_profile

  • 如果你使用zsh(Mac新系统默认是zsh)那么配置 ~/.zshrc

#Flutter 镜像配置
export PUB_HOSTED_URL=https://pub.flutter-io.cn
export FLUTTER_STORAGE_BASE_URL=https://storage.flutter-io.cn

#Flutter 配置
export FLUTTER=/opt/flutter/bin
export PATH=$FLUTTER:$PATH

配置完成就执行 source ~/.bash_profile

那么接下来!我们可以看看 Flutter 是否配置完成了。Flutter有一个 doctor 检测指令。专门用于检测你的Flutter环境的。

flutter doctor

跑了一段时间你可以就会出现👇的情况, 在 AndroidVS code 配置没有成功

接下来我们去配置各个平台的 Flutter 的环境 去解决以下问题

[!] Android toolchain - develop for Android devices (Android SDK version 30.0.3)
    ✗ Android licenses not accepted.  To resolve this, run: flutter doctor --android-licenses

[!] Android Studio (version 4.1)
    ✗ Flutter plugin not installed; this adds Flutter specific functionality.
    ✗ Dart plugin not installed; this adds Dart specific functionality.
[!] VS Code (version 1.52.0)
    ✗ Flutter extension not installed; install from
      https://marketplace.visualstudio.com/items?itemName=Dart-Code.flutter
[!] Connected device
    ! Error: Cooci的iPhone is not connected. Xcode will continue when Cooci的iPhone is connected.
      (code -13)

6: 配置各个平台环境

① : 解决 android-licenses 问题
```
flutter doctor --android-licenses

后面一顿 y

top Created with Sketch.