B3ce9a1c7bb2b168ef122b232fa0c855
Flutter 安装与配置

您好,欢迎关注我的专栏,本专栏是关于Flutter的专栏,从简单的Flutter介绍开始,一步步带你了解进入Flutter的世界。你最好有一定的移动开发经验,如果没有也不要担心,在我的专栏底部给我留言,我会尽我的能力给你解答。

上篇文章我们简单的介绍了一下什么是Flutter,相信大家已经摩拳擦掌想真枪实弹的试一试了吧,本篇文章就介绍如何配置Flutter的开发环境。

本专栏默认使用MacOS + AndroidStudio/Xcode搭建开发环境,其它开发环境可以自行参考资料或给我留言。

系统要求

要安装并运行Flutter,您的开发环境必须满足以下最低要求:

  • 操作系统: macOS (64-bit)
  • 磁盘空间: 700 MB (不包括Xcode或Android Studio的磁盘空间).
  • 工具: Flutter 依赖下面这些命令行工具.
    bash, mkdir, rm, git, curl, unzip, which

获取Flutter SDK

先克隆beta分支,然后将该flutter工具添加到您的系统路径中:

git clone -b beta https://github.com/flutter/flutter.git
export PUB_HOSTED_URL=https://pub.flutter-io.cn //国内用户需要设置
export FLUTTER_STORAGE_BASE_URL=https://storage.flutter-io.cn //国内用户需要设置
export PATH=`pwd`/flutter/bin:$PATH

运行 flutter doctor

运行以下命令查看是否需要安装其它依赖项来完成安装:

flutter doctor
top Created with Sketch.